Possible regression since 1.45.2

I started working on a project again that I hadn't touched in a while, and noticed that it won't compile anymore on 1.46.0 or 1.47.0. Whenever I try, it eats up all the RAM on my system, then gets killed. It compiles fine on 1.45.2 and earlier.

Source code that fails to compile can be found at: https://github.com/iwismer/actix-auth-example. Nothing after commit 792039fa23a232ea5c7502878fd44c67cd6a3748 will compile with 1.46.0, and everything before that takes about 10x as long as with 1.45.0 on the same machine.

I have no idea what the regression is related to, but I've tried removing a bunch of the functionality and it still doesn't compile.

1 Like

This should probably be filed as an issue on the Rust repo.

It would help if you could generate a minimal example that demonstrates the problem, but the info you have here is probably sufficient to start with and if you file an issue folks can help out with minimizing it down.

This is probably https://github.com/rust-lang/rust/issues/75992.

1 Like

Thanks for the quick response. That seems like the same issue.