New rustup release staged and needing testers

Hi everyone, there is a new release of rustup staged on our dev environment and in need of testing.

You can find the changelog here: https://github.com/rust-lang/rustup/blob/stable/CHANGELOG.md

If you are prepared to test it, then if you have an existing install you can do:

env RUSTUP_UPDATE_ROOT=https://dev-static.rust-lang.org/rustup rustup self update

If you want to try in a fresh VM or user, in order to not risk your current setup, you can run:

curl --proto '=https' --tlsv1.2 -sSf https://dev-static.rust-lang.org/rustup/rustup-init.sh | env RUSTUP_UPDATE_ROOT=https://dev-static.rust-lang.org/rustup sh -

I'm interested in knowing if any of the new functionality seems to misbehave for anyone.

If you are using Illumos or arm64 macos then I'd very much appreciate an indication of whether or not things seem okay since they are new platforms for us.

Finally if you're a windows user, I'd appreciate an indication that I've not broken anything. I've tried my best to do testing on Windows when I can, but I'm not a native of that platform. I'm also unsure how to set the environment variable on Windows, so if a native user could comment with how to do it I'd appreciate that for others to use.

Thanks to anyone who can lend a hand to help.

Daniel.

1 Like

Oh, if you need to discuss anything with me, I'll be on #wg-rustup on the Rust-lang discord server (https://discord.gg/rust-lang) too.

A basic rustup update nightly on x86_64-linux after updating to it worked, but then it self-updated again and downgraded to the stable version :rofl:

Installing a channel with just minor version worked fine.

Using the new rust-toolchain format seems to try to sync the channel every time I run any command:

> rustc --version
info: syncing channel updates for 'nightly-2020-11-24-x86_64-unknown-linux-gnu'
info: latest update on 2020-11-24, rust version 1.50.0-nightly (d9a105fdd 2020-11-23)
info: component 'clippy' for target 'x86_64-unknown-linux-gnu' is up to date
info: component 'rust-std' for target 'thumbv6m-none-eabi' is up to date
info: component 'rustfmt' for target 'x86_64-unknown-linux-gnu' is up to date
rustc 1.50.0-nightly (d9a105fdd 2020-11-23)

with

[toolchain]
channel = "nightly-2020-11-24"
components = ["clippy", "rustfmt"]
targets = ["thumbv6m-none-eabi"]

aarch64-apple-darwin looks good to me!

% rustup self uninstall

% curl --proto '=https' --tlsv1.2 -sSf https://dev-static.rust-lang.org/rustup/rustup-init.sh | env RUSTUP_UPDATE_ROOT=https://dev-static.rust-lang.org/rustup sh -

Current installation options:

   default host triple: aarch64-apple-darwin
     default toolchain: beta
               profile: minimal
  modify PATH variable: yes

% file $(which rustup)
~/.cargo/bin/rustup: Mach-O 64-bit executable arm64

% rustup install nightly

  nightly-aarch64-apple-darwin installed - rustc 1.50.0-nightly (1c389ffef 2020-11-24)

% cd /tmp

% cargo new hola

% cd hola

% cargo run
   Compiling hola v0.1.0 (/private/tmp/hola)
    Finished dev [unoptimized + debuginfo] target(s) in 0.39s
     Running `target/debug/hola`
Hello, world!

% file target/debug/hola
target/debug/hola: Mach-O 64-bit executable arm64
1 Like

Oh dear, this isn't good. I shall attempt to replicate this locally, thank you for the report.

Issue filed here - https://github.com/rust-lang/rustup/issues/2571 Thanks again

PR here - https://github.com/rust-lang/rustup/pull/2573

if that goes well I'll sort out a rerun of the dev release.

1 Like

Works fine for me on x86_64-pc-windows-msvc. Regarding environment variables on Windows: That depends on the shell you use. I don't really use the windows shells much, but this worked for me:

  • PowerShell: $env:RUSTUP_UPDATE_ROOT="https://dev-static.rust-lang.org/rustup"
  • cmd: set RUSTUP_UPDATE_ROOT="https://dev-static.rust-lang.org/rustup"

One thing I'd like to mention is that I get the following warning if use the new toolchain file format: warning: Force-skipping unavailable component 'rust-std-x86_64-unknown-hermit'.

Toolchain:

[toolchain]
channel = "nightly-2020-11-24"
components = [ "rustfmt", "rust-src", "llvm-tools-preview"]
targets = [ "x86_64-unknown-hermit" ]

I don't think that warning is necessary, since the hermit target is shipped by default.

Rustup doesn't know that though :confused: Thanks for checking, and for the windows help.

We've updated the version of rustup on the staging server to close the issue reported by Nemo. I would appreciate any further testing, and we'll aim for a release later today.