Looking for a mentor to fix bug (#80258)

Hi,

I'm looking for someone to guide me through fixing #80258. That bug has been bothering me for a while, and I have the time to work on it on weekends.

I already asked for help in the issue and rust-lang Zulip, but got no help other than "just read the code", "just read the docs", and "just grep for it". I have experience in finding my way around in large code bases, but I don't have that much time to invest on this (I have maybe 4-5 hours a week), so if anyone could help (at least point me to the relevant modules) that would be much more efficient for me and I could probably do it in a week or two.

I know how to enable trace logs and add new ones. I also read most of the rustc dev guides out there.

So far what I tried is reading modules that checked or computed method receivers. Mainly the type checker's wfcheck. I think the problem is not in wfcheck. I don't know where else to look next. I also tried finding the code that throws the error, and trace the execution to the point of error.

Thanks.

4 Likes

First and last bump before I ditch this

Zulip is the correct place to ask for this, most of the compiler team doesn't monitor this forum.

I suggest looking into rustc_typeck/src/check/method/probe.rs.

Thanks. As I say in the original message I already tried Zulip. I'll take a look at that module