Rename `dynamic_lib` to `dylib`


The module name dynamic_lib is a bit long compared to other module names in std, and there is abbreviation dylib used by Cargo and the compiler. Rename the module to dylib for brevity and consistency?

Rename and stabilize `std::dynamic_lib`?

RFC 580 is recommending that much of the std library be renamed to be more consistent and less abbreviated than before. This goes the opposite direction. Maybe this discussion makes sense there also…

EDIT: Oops. Missed that it was strictly collections.


@mdinger, RFC 580 is for renaming the standard collections (not the other parts of the standard library) as they have inconsistently abbreviated names, and my (currently and only slightly) preferred solution is to rename BinaryHeap to BinHeap, which makes it more abbriviated.

Still there are many who favour the no abbriviations here alternative.

And on this topic of renaming dynamic_lib to dylib, I agree with OP. This is a good idea.

closed #4

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.