About the bikeshed (deprecated) category
|
|
1
|
1442
|
March 25, 2019
|
Suggestion: references in struct literal
|
|
10
|
1521
|
March 25, 2019
|
Renaming FnOnce to FnMove?
|
|
8
|
3245
|
March 25, 2019
|
Target_os: it's called OS X not Mac OS
|
|
10
|
7104
|
March 25, 2019
|
Null pointers
|
|
2
|
1848
|
March 25, 2019
|
Generics verbosity
|
|
5
|
2156
|
March 25, 2019
|
Fix inconsistent naming before 1.0
|
|
20
|
3711
|
March 25, 2019
|
"Function pointers" should not be named as such
|
|
1
|
1834
|
March 25, 2019
|
Replace Point { x: 3, y: 5 } with Point { x=3, y=5 }
|
|
72
|
9749
|
March 27, 2015
|
On Casts and Checked-Overflow
|
|
50
|
10909
|
March 25, 2019
|
Rename and stabilize `std::dynamic_lib`?
|
|
1
|
1500
|
March 25, 2019
|
Any chance PathBuf could be renamed?
|
|
7
|
1980
|
March 25, 2019
|
Add an optional "+" prefix to numeric literals
|
|
8
|
3432
|
March 25, 2019
|
Vec in std::vec rather than std::collections?
|
|
2
|
1501
|
March 25, 2019
|
The need for dereferencing
|
|
2
|
1590
|
March 25, 2019
|
Rename 'type' to 'alias' before 1.0!
|
|
31
|
6091
|
March 25, 2019
|
Extend range notation to allow the equivalent to matlab's "1:(end - 5)"
|
|
17
|
4568
|
March 25, 2019
|
[Pre-RFC] Generation of item idents in macros
|
|
9
|
3889
|
March 25, 2019
|
[Pre-RFC] use ... instead of .. in pattern ellisions
|
|
8
|
2200
|
March 25, 2019
|
Inconsistent syntax for normal range and match range
|
|
17
|
7388
|
March 25, 2019
|
Trait importing syntax
|
|
9
|
4616
|
March 25, 2019
|
The inconsistencies in std collections' names and one possible solution
|
|
3
|
1755
|
March 25, 2019
|
Rename println! to print!
|
|
10
|
3270
|
March 25, 2019
|
Use a more clear suffix for isize and usize literals (isz and usz?)
|
|
3
|
5182
|
March 25, 2019
|
Addition of a new `unreachable` macro
|
|
3
|
1524
|
March 25, 2019
|
Copy impl for random number generators
|
|
8
|
2217
|
March 25, 2019
|
Call for consensus, if we do want rename `int/uint`
|
|
19
|
4173
|
March 25, 2019
|
num_cpus --> cpu_count
|
|
3
|
2092
|
March 25, 2019
|
Would having both `iptr/uptr` and `idiff/usize` in Rust be a good idea? (Answer: No.)
|
|
5
|
2577
|
March 25, 2019
|
If `int` has the wrong size ...?
|
|
26
|
5666
|
March 25, 2019
|