I often have to convert a std::result::Result into an std::option::Option (very useful when chaining different Option and Result types using and_then()). This is easy with the ok() function. The problem is that you lose the Err(_), which is expected though, since Option only has None. But what if I still want to do something with the error message, for example log it?
The issue I see with the name Result::ok_or_else specifically is Option::ok_or_else(). The 2 methods have quite different behavior, so giving them the same name doesn't sound great to me.
My personal feeling is that Result and Option already have so many (proposed) methods that discoverability suffers. A new method would need to make useful patterns much more readable and/or shorter.
The map_err variant already looks clear to me and is just two characters longer. I think the name of your proposed method should make clear that the error is consumed. Something like drop_err_with as a counter part to the nightly inspect_err. Not sure if drop is the correct verb though.