Naming consistency: Path/PathBuf


This is a relic of the older StrBuf era i think…

I think it sets up a pretty inconsistent example of naming. Is it possible to rename those somehow?


You can create type aliases, but that’s about it I think, we can’t actually rename the types because that would be a breaking change.

1 Like

Previous discussions:

Any chance PathBuf could be renamed? Mar’15

Pre-RFC: Rename Path and PathBuf Oct’17


Heck, if anything I think they’re the ones with the right names; I’d have preferred str and StrBuf. Oh well!

closed #5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.