[Article] Compatibility with dependencies


#1

I’ve seen a lot of discussion around backward-compatibility, minimal rustc versions and LTS releases in the past few days and I believe they lack a theoretical foundation. Therefore I did some math.

The resulting article may be found here.

Please feel free to use this thread for feedback and discussion.

In case you find bugs or other shortcomings (even little tiny ones), please file an issue or a pull request on the repository.