I was looking at this code in Rust today:
and I'm wordering if we couldn't use this as the standard style:
This is something I've adopted in my own code, because it feels marginally cleaner -
Intersection is an ident, it's the name of a type (and if the type renames, so should we change this string in the Debug impl too).
Thoughts on this? I know it's a small thing and feels low-tech, but small things like this add up in refactoring. How do Rust's current refactoring tools handle renaming Intersection in this code?