Upcoming changes to rustc build requirements


#1

As a heads up, we’ve just landed an update to LLVM’s upcoming 3.9 release branch, and with it comes some updated requirements for building LLVM. Notably CMake version 3.4.3 is the minimum required. If you’re on Ubuntu 16.04, the system cmake is fine, but prior to that you’ll need to install a new version manually.

Also with LLVM upgrades tend to come some rocky times for building, so if you see anything odd please feel free to file an issue!