Bikeshedding target version (RFC PR #1147)


#1

For the recently rewritten RFC PR #1147 Target Version, a few denominators could use some bikeshedding:

  1. Cargo has a package attribute whose name is currently defined as ‘rust’. Alternatives include:
  • std (but this may confuse people who use --nostd)
  • rust_lang
  • target
  1. rustc needs a command line option, currently named ‘–target-version=1.2.0’. This could be:
  • –std
  • –source
  • –version

I’m sure there are other options I haven’t yet considered. So what do you think?


#2

Link:


#3

Thanks, fixed.