Bikeshed: Rename `catch` blocks to `fallible` blocks

I also think that it’s best not to use the catch keyword because its meaning would be different in Rust than elsewhere (languages with exceptions). A keyword that signifies that the error propagation is stopped though would be nice.

Some synonyms to catch:

accept
capture
collect
recover
resolve
take
trap 
3 Likes