Before I read the write up, I’m kinda in favor of prefix… but after reading it I started thinking postfix is probably better. Also I think it would be cool to have await
be separated by whitespace, so that if you don’t have much stuff, you can do:
let foo = get_foo() await?;
and in case you want to chain multiple await, you can
let foo = get_bar() await?
.get_foo() await?;
which seems to be quite nice.