Currently we use
if let Some(x) = option, which works, but is a bit verbose.
This will be more ergonomic, because we don’t need pattern matching in most of the times.
The same idea already applied in
for x in iter syntax, which effectively replaces
while let Some(x) = iter.next().
With implementing this, Rust will be more consistent.
std::ops::Try types might be supported.
Considering how commonly they are used, code should be easier to read, write, and maintain.