# Triage digest: Mon Feb 01 2016

**URL:** <https://internals.rust-lang.org/t/triage-digest-mon-feb-01-2016/3142>\
**Category:** Uncategorized\
**Created:** [February 1, 2016, 7:03pm UTC](https://internals.rust-lang.org/t/triage-digest-mon-feb-01-2016/3142 "2016-02-01T19:03:06Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![triagebot](https://avatars.discourse-cdn.com/v4/letter/t/e480ec/32.png) [@triagebot](https://internals.rust-lang.org/u/triagebot)\
**Post date:** [February 1, 2016, 7:03pm UTC](https://internals.rust-lang.org/t/triage-digest-mon-feb-01-2016/3142/1 "2016-02-01T19:03:06Z")

</div>

## Nominated (I-nominated) issues

### [Tracking issue for stabilizing randomness (#27703)](https://github.com/rust-lang/rust/issues/27703)

- Added **I-nominated**. By @aturon

### [Tracking issue for string patterns (#27721)](https://github.com/rust-lang/rust/issues/27721)

- Added **I-nominated**. By @aturon

### [Tracking issue for DST coercions (coerce\_unsized, unsize) stabilization (#27732)](https://github.com/rust-lang/rust/issues/27732)

- Added **I-nominated**. By @aturon

### [Tracking issue for `str_char` stabilization (#27754)](https://github.com/rust-lang/rust/issues/27754)

- Added **I-nominated**. By @aturon

### [Set recovery methods (#28050)](https://github.com/rust-lang/rust/issues/28050)

- Added **I-nominated**. By @BurntSushi

### [associated constants should support references to outer type parameters (#28809)](https://github.com/rust-lang/rust/issues/28809)

- Added **I-nominated**. By @pnkfelix

### [Warn must\_use in tuple (#29815)](https://github.com/rust-lang/rust/issues/29815)

### [Move Duration to libcore (and remove deprecated Duration::span) (#30594)](https://github.com/rust-lang/rust/issues/30594)

### [DragonflyBSD build is broken (#31009)](https://github.com/rust-lang/rust/issues/31009)

### [Linking regression in 1.6 (#31150)](https://github.com/rust-lang/rust/issues/31150)

### [Windows linker regression in 1.6 (#31151)](https://github.com/rust-lang/rust/issues/31151)

### [Pattern guard can consume value that is being matched (#31287)](https://github.com/rust-lang/rust/issues/31287)

- Added **I-nominated**. By @alexcrichton

### [Bogus error in beta and nightly: recursive type has infinite size (#31299)](https://github.com/rust-lang/rust/issues/31299)

- Added **I-nominated**. By @alexcrichton

## Beta-nominated issues

### [std: Stabilize custom hasher support in HashMap (#31081, closed)](https://github.com/rust-lang/rust/issues/31081)

### [1.7 release notes (#31099, closed)](https://github.com/rust-lang/rust/issues/31099)

### [mk: Move from `-D warnings` to `#![deny(warnings)]` (#31120, closed)](https://github.com/rust-lang/rust/issues/31120)

### [implement RFC amendment 1462 (add `[` to FOLLOW(ty)) (#31152, closed)](https://github.com/rust-lang/rust/issues/31152)

### [trpl: fix macro follow sets (#31240, closed)](https://github.com/rust-lang/rust/issues/31240)

## Remaining issues

### [Tracking Issue for RFC 213: Default Type Parameter Fallback (#27336)](https://github.com/rust-lang/rust/issues/27336)

- Removed I-nominated. By @aturon

### [Tracking issue for `str_utf16` stabilization (#27714)](https://github.com/rust-lang/rust/issues/27714)

- Added **I-nominated**. By @alexcrichton
- Removed I-nominated. By @alexcrichton

### [Tracking issue for Scoped TLS (#27715)](https://github.com/rust-lang/rust/issues/27715)

- Added **I-nominated**. By @sfackler
- Removed I-nominated. By @alexcrichton

### [Tracking issue for `thread_local_state` stabilization (#27716)](https://github.com/rust-lang/rust/issues/27716)

- Added **I-nominated**. By @alexcrichton
- Removed I-nominated. By @alexcrichton

### [Tracking issue for `recover` stabilization (#27719)](https://github.com/rust-lang/rust/issues/27719)

- Added **I-nominated**. By @alexcrichton
- Removed I-nominated. By @alexcrichton

### [Tracking issue for `borrow_state` stabilization (#27733)](https://github.com/rust-lang/rust/issues/27733)

- Added **I-nominated**. By @alexcrichton
- Removed I-nominated. By @alexcrichton

### [Tracking issue for `cell_extras` stabilization (#27746)](https://github.com/rust-lang/rust/issues/27746)

- Removed I-nominated. By @alexcrichton

### [Tracking issue for `wait_timeout_with` stabilization (#27748)](https://github.com/rust-lang/rust/issues/27748)

- Added **I-nominated**. By @sfackler
- Removed I-nominated. By @alexcrichton

### [Tracking issue for ::{as\_ref, as\_mut\_ref} (#27780)](https://github.com/rust-lang/rust/issues/27780)

- Added **I-nominated**. By @alexcrichton
- Removed I-nominated. By @alexcrichton

### [Tracking issue for make\_ascii\_{upper,lower}case (#27809)](https://github.com/rust-lang/rust/issues/27809)

- Removed I-nominated. By @alexcrichton

### [Tracking issue for drop\_in\_place (#27908)](https://github.com/rust-lang/rust/issues/27908)

- Added **I-nominated**. By @sfackler
- Removed I-nominated. By @alexcrichton

### [Tracking issue for overloaded `+=` operators (RFC 953) (feature augmented\_assignments) (#28235)](https://github.com/rust-lang/rust/issues/28235)

- Added **I-nominated**. By @sfackler
- Removed I-nominated. By @alexcrichton

### [Tracking issue for `braced_empty_structs` (RFC 218) (#29720)](https://github.com/rust-lang/rust/issues/29720)

- Removed I-nominated. By @aturon

### [Expand the std::time module (#29866)](https://github.com/rust-lang/rust/issues/29866)

- Added **I-nominated**. By @alexcrichton
- Removed I-nominated. By @alexcrichton

### [Nightly does not work on some Debian Wheezy because gcc doesn't support gold. (#30783)](https://github.com/rust-lang/rust/issues/30783)

- Removed I-nominated. By @alexcrichton

### [Linking with gold does not search /usr/local/lib (#30784)](https://github.com/rust-lang/rust/issues/30784)

- Removed I-nominated. By @alexcrichton

### [In cross-compiled i686-\>x86\_64 code, thread::spawn crashes on my system (#31139)](https://github.com/rust-lang/rust/issues/31139)

- Added **P-high**. By @nikomatsakis

triage: P-high

### [Massive compiler perf regression (#31157)](https://github.com/rust-lang/rust/issues/31157)

- Added **P-high**. By @nikomatsakis

triage: P-high

### [There is no way to `unsafe impl` `'static` (#31196)](https://github.com/rust-lang/rust/issues/31196)

- Added **I-nominated**. By @huonw
- Removed I-nominated. By @aturon

### [Create a benchmark suite for uncovering compile time regressions (#31265)](https://github.com/rust-lang/rust/issues/31265)

- Added **P-medium**. By @nikomatsakis
- Added **I-nominated**. By @nikomatsakis
- Removed P-medium. By @nikomatsakis
- Added **P-medium**. By @nikomatsakis

triage: P-medium

### [Panic on None when joining on thread which is called yield\_now (#31316)](https://github.com/rust-lang/rust/issues/31316)

- Added **I-nominated**. By @alexcrichton
- Removed I-nominated. By @alexcrichton

[Permalink to this digest](http://www.ncameron.org/triage/digest?date=2016-02-01T19-03-06-012Z)

---

<div class="post-metadata">

**Author:** ![triagebot](https://avatars.discourse-cdn.com/v4/letter/t/e480ec/32.png) [@triagebot](https://internals.rust-lang.org/u/triagebot)\
**Post date:** [March 25, 2019, 8:25am UTC](https://internals.rust-lang.org/t/triage-digest-mon-feb-01-2016/3142/2 "2019-03-25T08:25:45Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
