Poor naming of read()/write() I/O methods

There also seems to be a small parallel with the recent #[must_bind] thread. In that thread, it was observed that not binding a guard is often wrong in subtle ways (and #[must_use] doesn't really help). In this thread, the #[must_use] on the return from Read::read() also doesn't really help, because it's often wrong to ignore the usize within the Ok variant.

4 Likes