Bikeshed: Rename `catch` blocks to `fallible` blocks

I'm thinking the same thing. From Bikeshed: A consise verb for the `?` operator - #56 by illustrious-you :

let _: Result<Foo, Bar> = eval { // like "evaluation"
    foo()?;         // try operator
    fail Bar(0);    // break w/ err-wrapping, replaces throw
    pass Foo(0);    // break w/ ok-wrapping
    Foo(0)          // implicit Ok-wrapping
}