I'm not sure it's better enough to overcome the friction of __
already being a valid identifier. Hopefully there aren't too many people using things like mod __;
, but they could be. And it feels a bit more like Stroustrup's Rule than necessarily a substantial difference.
If we're jumping to something other than leveraging the existing "_
means 'infer this type'" we have from things like Vec<_>
, then I'd rather pick a different syntax entirely. For example, I've mentioned the Swift-inspired idea of let .{ x, y, .. } = foo();
or if let .V6(ip) = get_ip()
before.